Back to overview

Server Lag and Timeout

May 31, 2025 at 12:00pm UTC

Resolved
Jun 05, 2025 at 07:06am UTC

Lag Fixed.

Created
May 31, 2025 at 12:00pm UTC

You may experience various crashes and server lag, which will be fixed soon.
2b2t is aware of the ongoing lag and timing out issues over the last few hours.